Jump to content


David's Content

There have been 11 items by David (Search limited from 26-September 21)


By content type

See this member's

Sort by                Order  

#4213 Scheduling Issue

Posted by David on 06 March 2007 - 11:56 AM in AccuTrack 9

Hi Mon,

We're having a strange issue that has just cropped up. We haven't made any changes to our system that I am aware of other than creating two custom weeks to add to our current semester.

The issue is this: When we use the Appointment Wizard, the range of times we get for setting the appointment (in the drop down list) shows unusual times (e.g., 11:25am, 11:35am, etc.) even though the system is set to allow appointments only on the half hour and hour. Furthermore, these time selections change as the time (actual time) changes. For example, at 11:12 am, the time listed were 11:15am, 11:30am, 11:45am, etc. At 11:18 am, time listed were 11:20am, 11:40am, etc. It seems like AccuTrack is somehow reading the current time in making it's determination. This has begun to happen sporadically.

Any idea what's going on? Will v9.1 correct this? Is there any danger in applying the upgrade?

David - WSU



#3846 Import Error

Posted by David on 21 November 2006 - 03:08 PM in AccuTrack 9

This is funny, but another AccuTrack user reported the exact same error about an hour ago.  I asked them to send their error log, and the error log showed that the problem occured when the Import Wizard tried to load their ID mask, which was set to "xxxxxxxxx".  The correct format of the mask should be "XXXXXXXXX".  When I tried the lower case mask on my system I got the same error message both of you reported.  When I used the correct format (upper case) of the mask, the error disappeared.

This makes sense as the software does not recognize the 'x' as a valid formatting character for the mask ID.  The mask ID is used in the Import screen to verify that the ID in the import file has the correct format.  The ID format is loaded when the Import screen is launched, which was causing this error.

<{POST_SNAPBACK}>

Thanks, Mon. I bet the reason two of us reported it on the same day is because the use of the lower case x in the mask seems to work just fine until the import occurs. We had no problems with the mask setting when we manually imported records or during normal operation of the software until the import. This suggests that maybe some error trapping within the software isn't working as it should. A minor error under most circumstances until a part of the program with more rigorous error trapping is launched.

By the way, the documentation shows the capital X in the table, but it doesn't contain anything that specifies that lower case is prohibited. Again, this is a small issue, but might help clarify the situation in the future, especially since the software allows the user to make the mistake. (And we will make them).  :-)

Thanks for the quick feedback on all of this guys.

Happy Holidays to you, the rest of the staff, and your families.

David



#3841 Import Error

Posted by David on 21 November 2006 - 02:34 PM in AccuTrack 9

Hi David,
I think what you hit is an error that'd happen on rare circumstances and already fixed in internal built.
Would you test this:
Rename all files with a .dat extension to say .bkd and retry.
Please inform me of the result.

<{POST_SNAPBACK}>

Actually, I think I figured out what was happening. I went to a clean database and ran some tests. All went well until I changed the ID setting. The ID setting when I got the errors was "xxxxxxxxx" When I changed it to "XXXXXXXXX" the error stopped occuring. I was able to import with no problem.

This kind of makes sense to me for the "Function argument value, type, or count is invalid" message. However, I'm not sure it explains the "Invalid subscript reference" error.

I don't know if this is related to the the fix you wanted me to try, but it appears to have fixed my problem.

Does this explanation for the problem make sense to you guys? Is it possible it is valid?

David



#3839 Import Error

Posted by David on 21 November 2006 - 01:07 PM in AccuTrack 9

Perhaps there is a problem in the import file that you cannot see.  The best way to check is to open the file with MS Excel and if it opens OK, to do a "Save As" from Excel and select "CSV".  You can then use the saved file in AccuTrack for import.  Try it and let us know if this helps.

<{POST_SNAPBACK}>



Mon,

I did that to produce the .csv file. The original Excel file looks fine and so does the .csv.

What next?

David



#3834 Import Error

Posted by David on 21 November 2006 - 11:50 AM in AccuTrack 9

I am trying to import student information from a .csv file using the Import function in v9.03. I took an existing database and deleted the Category data and all of its sub-data. I have also inactivated most of the tutors (all but two). I imported Activity data with no problem. All of these actions preceded the import error.

When I tried to import the Student Information, I clicked on Import and got an "Error #31 Invalid subscript reference." I clicked Cancel on the resulting dialog and got an "Object OAPP is not found" message. I clicked Ignore and the program shut down.

Then I restarted the program, repaired the database and proceded to try another import. When I clicked on Import, I got a program error, "Invalid subscript reference." This time I clicked Ignore and the program started up the Text Import Wizard. All looked normal. I selected the .csv file I wanted to import and the target table, Student Information. I clicked Next. The proper screen came up and I selected the csv file type and left the field delimiter at Comma. The data looked great. I clicked the Next button. I got the column screen and dragged the column headers to the appropriate fields (I am sure I got them right as I have reproduced this error many times). I am only using the ID, First Name, Last Name, and Email fields.

I then clicked the Finish button and got the following message: "Function argument value, type, or count is invalid. Since I repeated the process several times, I can report that when I click Ignore in response to this message, I get the message again. When I click Cancel, the program shuts down.

On one previous attempt, the import utility actually imported a record consisting of a lone comma. In other words, I had one student record that was just a comma. On another occassion, it did not import anything, but it did not shut down.

The data looks good and there doesn't appear to be any unusual field lengths.

Any idea what's happening?



#3823 Custom Report

Posted by David on 20 November 2006 - 09:40 AM in AccuTrack 9

AccuTrack v9.03 has a great feature that notes which user made changes to the schedule. This ability, however, only appears to be accessible in the reports available in the Students Central screens. These reports do not appear to be customizable.

As an administrator, I really like that I can see who among my staff scheduled or cancelled an appointment. However, I'd also like to be able to see who signed a student in for the student's session (we manually enter all our sessions). I might be able to create a report using the Customizable Reports, but I don't know what the appropriate table and field is to capture the data. Is there some documentation about the database schema that explains each of the fields and what data each field holds? Or, is there some other way to get this report?

Thanks,
David



#3540 Appointments - "Given period conflicts with tutor'

Posted by David on 11 September 2006 - 09:35 AM in AccuTrack 9

When will v9.0.3 be available and how can users get the update?



#3502 Appointment Scheduling Issue

Posted by David on 05 September 2006 - 02:52 PM in AccuTrack 9

We're having scheduling difficulties too, but I'm not sure if this is related to ncandela's issue, so I'm making it its own post.

When we try to schedule an appointment, we are getting the following message: "Tutor has specific schedule that doesn't allow setting of this appointment." We did not see this in testing. What's even more weird is that when we exit out of the Appointment Wizard and go back in, it allows us to schedule the appointment. The net result, then, is that we have to schedule the appointment twice before AccuTrack (v9.02) will accept the appointment.

We have all of our tutors loaded into the database. They have their schedules and are each assigned all possible tasks ("Assignments"). Each tutor on the Tutors screen has the same Start Date and End Date as the Semester. We allow them a Max of 2 students per appointment, and we have set each tutor to "Use configuration setting" under the "Can tutor serve different activities during group session?" area. This has also been set to "No, cannot serve" and we got the same results. Our Pay method is For Work hours. We have no Tutor or Center Off Times currently scheduled. (I can't think of any other relevant settings).

We have tried to reboot with no change in the behavior. Any idea how to fix this? As is, it takes too long to schedule a client if we continue to have to do everything twice.



#3477 Windows - No Disk message

Posted by David on 31 August 2006 - 10:23 AM in AccuTrack 9

Mon,

I created a new shortcut, but that gave me the same message when I used it to start the program.

Let me know what you want me to try next.

David



#3452 Windows - No Disk message

Posted by David on 25 August 2006 - 08:16 AM in AccuTrack 9

Mon,

I double-clicked the acutrack.exe file and did NOT get the error. That's good news, I suppose. What does it mean?  :)

David

Can you try this on that same computer:

1. Using Windows Explorer, browse to C:\Program Files\Accu90
2. Look for the 'acutrack.exe' file and double click on it to launch.

Do you still get the same error?

<{POST_SNAPBACK}>




#3432 Windows - No Disk message

Posted by David on 22 August 2006 - 10:08 AM in AccuTrack 9

When I launch AccuTrack v9.02, I get a message box that says, "There is no disk in the drive. Please insert a disk into drive." It give me buttons to Cancel, Try Again, and Continue.

When I click on Cancel or Continue, the software loads. When I click on Try Again it pops the message back up. There doesn't seem to be any impact on the performance of the software, but the message is annoying and might be confusing to new users.

Any idea what is happening? Is there a fix?